WP将逐渐停止支持PHP4及Mysql4

2010年7月26日03:08:08 关注wordpress 6 1

WordPress最近通过官方博客宣布,2010年末发布的WordPress 3.1将成最后一个支持PHP 4和MySQL 4的版本。明年上半年发布的WordPress 3.2则需要具备PHP 5.2或MySQL 5.0.15或以上版本。

  WordPress表示,2010年末发布的WordPress 3.1将成为最后一个支持PHP 4的版本。将于2011年上半年发布的WordPress 3.2最低需要使用PHP 5.2,因为“这是绝大多数WordPress用户正在使用的版本,而且对早先的PHP 5进行了实质性改进”。而Drupal和Joomla等内容管理系统即将于今年晚些时候发布的最新版本也将PHP 5.2设定为最低要求。

  数据显示,WordPress用户中目前只有11%使用PHP 5.2以下版本。在这些用户中,其实有很多主机已经可以支持PHP 5.2,只需要在控制面板中激活即可。WordPress认为,今后使用PHP 5.2以下版本的用户还将继续减少。

  除此之外,在WordPress 3.1以后的版本也将停止对MySQL 4的支持。目前只有不到6%的WordPress用户使用MySQL 4。WordPress 3.2必须要使用MySQL 5.0.15及以上版本。

  如果用户的托管环境不满足上述要求,便无法升级到WordPress 3.2。为了方便用户判断,WordPress还提供了一个名为“Health Check”的插件来帮助用户了解当前的托管主机是否满足WordPress 3.2的配置要求。

所以各位在购买WordPress主机(WopusIDC)之前,最好问清楚当前服务器的配置已经今后的升级计划,尽量避免出现尴尬的问题。Wopus之前有用户从其他IDC搬迁过来,理由就是之前的IDC提供的Mysql版本不支持WordPress 3.0版本。

评论已关闭!

目前评论:6   其中:访客  6   博主  0

    • 永恒之塔基地 永恒之塔基地 1

      传说中的沙发!SQL4貌似已经淘汰了

      • 小子 小子 0

        mysql5还比较好呵呵

        • TongFeng TongFeng 0

          地板也不错!!

          • 东莞妇科医院 东莞妇科医院 3

            PHP5.2会不会好用一点

            • 林奕彬 林奕彬 0

              请问?目前哪一款支持 mysql服务器版本: 4.0.24 的

                • 酋 长 酋 长 9

                  @林奕彬 几乎都没了。现在都是5.0了。