WP主题和插件将显示可以运行的PHP最低版本

2017年8月3日01:07:51 关注wordpress 发表评论 864

WordPress程序版本很多,有些用户依然在使用比较老的WordPress程序,而PHP版本的使用跨度也非常大,虽然现在WordPress 4.8已经不能在php 5.2运行了,但依然有很多用户在php 5.3版本上运行WordPress,但这样的问题,长时间会引起一些困扰。

随着WordPress的程序更新,对php的版本要求更高,可能今后都是php 5.5+,而WordPress官网希望2017年年底WordPress能在PHP 7上运行,那么官方的主题和插件也要兼容最新版的WordPress程序,这样一来也肯定需要兼容更高版本的php。

但现在的问题是,主流插件和主题肯定会兼容及时兼容最新版的WordPress程序,但这些插件不可能在做向上兼容的同时也还能一直保持向下兼容,所以,WordPress官方准备在WordPress 4.9版本增加一个新的功能:WordPress插件和主题会显示最新能运行的php版本。

WP主题和插件将显示可以运行的PHP最低版本

这样做的好处显而易见,比如Wopus昨天就遇到了一个问题:

一个用户的主题从2010年开始就没有更新过了,但Wopus的主机更新了PHP和Mysql的版本,导致网站不能正常使用,如果WordPress官方有了主题运行的最低的PHP版本,那么这种问题就可以很容易解决,而不用去看日志,导出寻找解决办法了。

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: