两种移除WordPress版本提示功能方法

从WordPress 2.5开始,WordPress版本提示功能移植到了wp_head()函数中,这个功能是WordPress官方默认推广的。但是WordPress版本提示功能不是所有人都喜欢,在 9种增强WordPress安全性的方法中也有提到暴露当前使用WordPress版本的缺点,今天Wopus分享两种移除WordPress版本提示功能的方法。

查看博客当前WordPress版本一般有两种方法,有一种是直接暴露在博客页面上的,很多博客都把在Footer里加上代码,直接和WordPress博客最下面看到,第二种是隐性的,可以通过查看WordPress博客首页的源代码看到,在head区域,可以看到如下代码:meta name="generator" content="WordPress 2.8.4",希望各位都尽量不要暴露自己WordPress博客使用版本。

一,修改代码移除。

打开当前使用主题的functions.php文件(新手玩WordPress必备工具),把以下代码添加进去:
remove_action('wp_head', 'wp_generator');
这样就可以阻止wp_generator在wp_head里发生作用。

第二种方法:使用插件

在WordPress官方,有一些插件可以实现去除WordPress版本提示功能。很简单,不需要教程,插件地址:http://wordpress.org/extend/plugins/tags/version

目前评论:12   其中:访客  11   博主  0   引用   1

  1. avatar cuiqingyao 5

    我加了,是加在最下面,然后就出现问题了,

    就是这句代码直接显示在页面上了,CSS也出错了。

    • avatar 酋 长 5

      @cuiqingyao 都测试了有问题?

  2. avatar 聪壹艮 0

    博主这个现在测试了吗? 我是说改代码那个,可用不…

  3. avatar 魔兽世界 0

    正想作个博客

  4. avatar jason 2

    2.9.2是不是隐藏掉了?我怎么没看到那段显示版本的代码?

    • avatar 酋 长 5

      @jason 嗯,在后续版本中,改进了。

  5. avatar jason 2

    remove_action(‘wp_head’, ‘wp_generator’);
    这段代码用在哪里?没效果,反而把博客搞乱了

    • avatar 酋 长 5

      @jason 重新覆盖即可。

      以后修改之前,记得先在本地备份。

  6. avatar 红树林网赚 1

    remove_action(‘wp_head’, ‘wp_generator’);在函数里添加这句后BLOG就出错了

  7. avatar 蘇主任 0

    直接到default-filters.php注釋掉了

评论加载中...

来自外部的引用: 1

  • 两种移除WordPress版本提示功能方法 – 网赚连连看分享堂

评论已关闭!